Exercise! - Polar FT7 not registering heart rate




pnkrckpixikat
03-22-2014, 08:07 PM
I just bought a Polar FT7 about a week ago and no matter what I do I cannot seem to get it to register my heart rate.

I am wetting the sensors- I have tried running it under water, using saliva, wetting it and my skin both.

I have experimented with various tightnesses ranging from secure but not tight to as tight as I could make it go.

And I have tried directly under the boobs in the middle, under the boobs towards my heart, running over my boobs to the middle, and over my boobs and towards my heart.

No matter what combination I do, when I start the HRM it searches for maybe 45 second to a minute than flashes 00. It isn't telling me to check the monitor or any error messages I have read about online, just stays at 00.

I do have a low resting heart rate (45-55) but I also tried it after running in place for a few minutes to check if that was the problem.

I am out of ideas and were hoping someone on here might have some?

Thanks in advance!


Tafadhali
03-25-2014, 08:28 AM
This is interesting. I just got a Vivofit with HRM. The Vivo works great but my HRM was dead out of the box. Just like you I tried it every which way. I even tried it on my son. The thing is just crap. I called Garmin and they're sending me a new HRM for free. Do you have the newest soft strap version? I'm wondering if there's a quality issue. Garmin was real, real quick to just send me another one.

Anyway, sounds like you have a bad one too. Call Garmin and get them to send you a replacement. Hopefully the replacement will work and last a while!

Edit: Call Polar rather! Jeeze, I missed the maker there. �� maybe Polar will be as cool as Garmin about an exchange. I feel a little better knowing DOA HRMs isn't just a Garmin issue.